Ask Your Question
0

Failed to flash Whitefox on Mac & Linux: No DFU capable USB device

asked 2018-04-20 08:25:03 -0500

shanab gravatar image

updated 2018-04-20 08:38:20 -0500

Hi guys,

Just received my WhiteFox keyboard today. Tried to flash it first on Mac by following the instructions here: https://github.com/kiibohd/controller...

So what I did is connect the keyboard, and then click the flash button on the back of the keyboard. I noticed it turns orange so that's good. And then run dfu-util -D kiibohd.dfu.bin after downloading the firmware.

But then I got the following error:

dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Match vendor ID from file: 1c11
Match product ID from file: b007
dfu-util: No DFU capable USB device available

I tried to do the same thing on Ubuntu, but it resulted in the same error as well.

Is there something I'm missing or does that mean that the keyboard is faulty somehow?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-04-20 11:14:12 -0500

HaaTa gravatar image
input.club

There are two things to try.

  1. sudo dfu-util -l
  2. A different USB C cable

One more thing you can try is cleaning the USB C Port on the WhiteFox with isopropyl alcohol just in case some solder flux residue got on it.

edit flag offensive delete publish link more

Comments

This is the output of dfu-util -l:

Found Runtime: [05ac:8294] ver=0146, devnum=5, cfg=1, intf=5, path="20-8", alt=0, name="UNKNOWN", serial="UNKNOWN"

I'll try to use another USB-C cable, but I thought that since the button on the back turns orange then it should be getting power.

shanab gravatar imageshanab ( 2018-04-20 11:52:59 -0500 )edit

The Power and Gnd pins on a USB connector are longer and so they connect more easily. If the D+ and D- pins aren't connected then flashing won't work. The flash button will still work because the keyboard has power and is running.

HaaTa gravatar imageHaaTa ( 2018-04-20 11:59:54 -0500 )edit

I tried a different cable and unfortunately it didn't work.

shanab gravatar imageshanab ( 2018-04-21 03:21:33 -0500 )edit

Just double checking, you tried sudo dfu-util -l with the orange light on? And your Ubuntu install is on a separate computer (not a VM)?

HaaTa gravatar imageHaaTa ( 2018-04-21 14:18:57 -0500 )edit

Yes, the orange light was turned on. And I tried it on 3 different computers so far (1 Mac, 2 Ubuntu).

shanab gravatar imageshanab ( 2018-04-22 04:56:19 -0500 )edit
0

answered 2018-04-24 04:12:02 -0500

howj gravatar image

I had this problem in my MacBook as well, but fixed it in the following ways:

1) Used the stock braided USB-C cable 2) Unplugged all other USB devices

This means you'll need a non-USB keyboard / touchscreen / touchpad to get dfu-util to run.

edit flag offensive delete publish link more

Comments

howj, thanks for your answer. Unfortunately I don't have any USB devices plugged at this point and it still fails to recognize it.

shanab gravatar imageshanab ( 2018-04-24 12:03:04 -0500 )edit

Have you tried switching USB ports on your Mac? I found that one of the ports would make my Nightfox extremely finicking.

howj gravatar imagehowj ( 2018-04-27 10:36:55 -0500 )edit

I tried it on 3 different computers on multiple USB ports (with 2 cables also). I'm relatively certain by now that the issue is the keyboard itself.

shanab gravatar imageshanab ( 2018-04-27 16:55:42 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-20 08:25:03 -0500

Seen: 641 times

Last updated: Apr 24