Ask Your Question
0

Whitefox USB-C to USB-C not working

asked 2018-05-01 13:36:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Have a new whitefox that I have connected to a new MacBook Pro which only has USB-C ports on it. The Keyboard works fine with the USB-C to USB-A cable that came with it when I use a USB-C to USB-A Dongle to connect to the Mac.

I ordered a USB-C to USB-C data cable (some usbc only carry power and not data) which doesn't seem to work. I've tried 2 different USB-C to USB-C data cables from two different manufactures which work with other devices which don't work with the Whitefox. I've also flashed the whitefox to the newest version of Firmware as well.

Thanks Ray

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2018-05-01 21:21:20 -0500

Ray gravatar image

Tried a 3ed USBc to USBc cable and it seems to be working.. not sure whats going on.. now the first 2 I tried are working as well.. Gremlins in the PC I guess.

edit flag offensive delete publish link more
1

answered 2018-05-04 21:02:50 -0500

HaaTa gravatar image
input.club

I'd recommend cleaning your ports (both the keyboard and the mac) with Isopropyl alcohol.

Something like this: https://www.amazon.com/Swan-M314-Isop...

I usually use something like a syringe to put some inside the connector and rub the metal of the syringe on the contacts: https://www.amazon.com/Industrial-Syr...

edit flag offensive delete publish link more
0

answered 2018-05-02 22:03:23 -0500

SamPittman gravatar image

From your description, I am suspicious of the USB-C sockets on your Mac. Keep an eye on the sockets, and be wary of mechanical stresses such as moving the cable sideways, etc.

Glad you got some progress, though.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-01 13:36:07 -0500

Seen: 164 times

Last updated: May 04