Ask Your Question
0

can't work on Mac at all, but works on my other device

asked 2018-06-23 10:04:37 -0600

howj gravatar image

hey i need some urgent help - so here's what's happened.

My Nightfox was working beautifully with my Macbook Pro, connected via the stock USB-C to A cable at all times. Then I decided to flash it to tweak the layout of a few keys on Layer 1. After I flashed it, it would connect to my Mac and then disappear from the devices list. Now I can't get it to show up at all. I know the keyboard is fine cos I hooked it up to my Chromebook and it works as it used to ... so why is it suddenly not playing nice with my Mac?

Help! I sold off other keyboards so this is my current daily driver, and it can't work at all!

edit retag flag offensive close merge delete

Comments

Have you tried different USB ports on your Mac?

Did you use the client-side configurator to flash the keyboard (or the web ui)?

Also, which Macbook Pro do you have?

HaaTa gravatar imageHaaTa ( 2018-06-23 10:46:36 -0600 )edit

I tried all the USB ports on my Mac. I used the client side Kiibohd configurator, not the web in-browser one. I'm using a late-2011 17" Macbook Pro.

It works completely fine on my Chromebook Pixel though! And I just managed to get intermittent connections on my Mac.

howj gravatar imagehowj ( 2018-06-23 10:56:18 -0600 )edit

it will show up for a minute or so and work, and then it will disappear. I've noticed that sometimes, in Karabiner Elements, it will remain in the devices list but not work at all. Other times it will just disappear and never come back.

howj gravatar imagehowj ( 2018-06-23 10:57:31 -0600 )edit

ok, it was working for five minutes or so, and then keystrokes will start to lag and then it will stop registering completely, or to the point where it is unusable. In Karabiner Elements I can see multiple instances of "product": "Keyboard - WhiteFox:truefox PixelMap USB" showing up.

howj gravatar imagehowj ( 2018-06-23 11:03:39 -0600 )edit

thing is, it was working fine for months! what happened when I flashed it? I used to flash it with only the keyboard connected, just now I flashed it with the mouse connected as well. that might have affected it somehow.

howj gravatar imagehowj ( 2018-06-23 11:06:40 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-06-23 11:26:09 -0600

HaaTa gravatar image
input.club

NKRO keyboards don't work well with the USB Overdrive and Karabiner as they apply a lot of "hacks" to the system and always expect a 6KRO keyboard.

Options

  • Force the keyboard to run in 6KRO mode (you can test this by using the 6/N-KRO key)
  • Uninstall Karabiner (and USB Overdrive)
edit flag offensive delete publish link more

Comments

thanks @HaaTa. I didn't have USB Overdrive installed but uninstalling Karabiner seems to have worked. I do need Karabiner installed to make this keyboard work across all my devices, so I'm gonna try with a clean install and see how this plays out. Thanks anyway! sorry for the panic.

howj gravatar imagehowj ( 2018-06-23 11:38:54 -0600 )edit

sorry, i spoke too soon ... after uninstalling Karabiner the keyboard will work for a while and then just go off the grid. Sigh.

howj gravatar imagehowj ( 2018-06-23 11:47:11 -0600 )edit

That sounds like a bad USB cable (or a dirty connector on your Macbook Pro). I'd try a new cable and cleaning out the USB port. You may also want to clean the Nightfox USB connector with some isopropyl alcohol sometimes some flux gets on the connector pins which may cause packet dropping.

HaaTa gravatar imageHaaTa ( 2018-06-23 11:52:16 -0600 )edit

i'm sorry HaaTa but I doubt this very much. When the keyboard goes off the grid, I will unplug it and use the same stock cable and plug it straight into my chromebook, and it works flawlessly. All the USB ports work with my mouse all the time. There's something finicky about the PCB, I believe.

howj gravatar imagehowj ( 2018-06-23 11:55:52 -0600 )edit

So try plugging it into the chromebook and wiggling the cable to see if it still types. Generally if it's working with one computer, there's usually an issue with the computer itself (or the connector). Also, do you have the ability to try with another Mac? Have you tried 6KRO mode?

HaaTa gravatar imageHaaTa ( 2018-06-23 13:18:22 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-23 10:04:37 -0600

Seen: 99 times

Last updated: Jun 23