Ask Your Question
0

Flashing WhiteFox Doesn't Work?

asked 2018-09-27 20:17:23 -0600

bronlom gravatar image

Hi all,

I recently purchased the WhiteFox and I successfully programmed the keys and flashed a few times using the site https://input.club/configurator-white.... I tried out different layouts and on one layout I put LED- and LED+ on Layer 1. When I recently tried to configure again from the site, the file downloaded but when I try to flash and install, I get the following error:

➜ WhiteFox git:(master) $ dfu-util -D kiibohd.dfu.bin dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc. Copyright 2010-2016 Tormod Volden and Stefan Schmidt This program is Free Software and has ABSOLUTELY NO WARRANTY Please report bugs to http://sourceforge.net/p/dfu-util/tic...

Match vendor ID from file: 1c11 Match product ID from file: b007 Deducing device DFU version from functional descriptor length Opening DFU capable USB device... ID 1c11:b007 Run-time device DFU version 0101 Claiming USB DFU Interface... Setting Alternate Setting #0 ... Determining device status: state = dfuIDLE, status = 0 dfuIDLE, continuing DFU mode device DFU version 0101 Device returned transfer size 1024 Copying data from PC to DFU device Download [ ] 0% 0 bytesdfu-util: Error during download

I've tried using https://configurator.input.club/alpha... to download firmware, but this results in the same error. Someone please help!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-09-29 13:06:53 -0600

HaaTa gravatar image
input.club

Usually this means the WhiteFox is in secure bootloader mode. All you have to do if this happens is to press the reset button on the bottom of the keyboard.

edit flag offensive delete publish link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-27 20:17:23 -0600

Seen: 53 times

Last updated: Sep 29