Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Flashing WhiteFox Doesn't Work?

Hi all,

I recently purchased the WhiteFox and I successfully programmed the keys and flashed a few times using the site https://input.club/configurator-whitefox/. I tried out different layouts and on one layout I put LED- and LED+ on Layer 1. When I recently tried to configure again from the site, the file downloaded but when I try to flash and install, I get the following error:

➜ WhiteFox git:(master) $ dfu-util -D kiibohd.dfu.bin dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc. Copyright 2010-2016 Tormod Volden and Stefan Schmidt This program is Free Software and has ABSOLUTELY NO WARRANTY Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Match vendor ID from file: 1c11 Match product ID from file: b007 Deducing device DFU version from functional descriptor length Opening DFU capable USB device... ID 1c11:b007 Run-time device DFU version 0101 Claiming USB DFU Interface... Setting Alternate Setting #0 ... Determining device status: state = dfuIDLE, status = 0 dfuIDLE, continuing DFU mode device DFU version 0101 Device returned transfer size 1024 Copying data from PC to DFU device Download [ ] 0% 0 bytesdfu-util: Error during download

I've tried using https://configurator.input.club/alpha/?layout=WhiteFox-TrueFoxBlank to download firmware, but this results in the same error. Someone please help!